Bug report #7880

WFS-T client on master fails to save edits on a TinyOWS server

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16754

Description

It works on 1.8 (using obviously the very same server/layer).

Associated revisions

Revision 1ea6267c
Added by Jürgen Fischer over 6 years ago

wfsprovider: set srsName of new geometries (fixes #7880)

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Subject changed from WFS-T on master fails to save edits on a TinyOWS server to WFS-T client on master fails to save edits on a TinyOWS server

#2 Updated by Giovanni Manghi over 6 years ago

Now it seems that it affects also qgis server. see #7881

#3 Updated by Salvatore Larosa over 6 years ago

Hi Giovanni,

Could you provide any link for testing ?
Does it generate the same error of #7881 when you try to commit changes ?

#4 Updated by Giovanni Manghi over 6 years ago

Salvatore Larosa wrote:

Hi Giovanni,

Could you provide any link for testing ?
Does it generate the same error of #7881 when you try to commit changes ?

http://mapserver.uevora.pt/cgi-bin/tinyows

#5 Updated by Jürgen Fischer over 6 years ago

Giovanni Manghi wrote:

http://mapserver.uevora.pt/cgi-bin/tinyows

Inserting works neither in master nor 1.8 for me.

#6 Updated by Giovanni Manghi over 6 years ago

Jürgen Fischer wrote:

Giovanni Manghi wrote:

http://mapserver.uevora.pt/cgi-bin/tinyows

Inserting works neither in master nor 1.8 for me.

wait, I may have done something wrong server side.

#7 Updated by Salvatore Larosa over 6 years ago

I tested the service on both master and 1.8
and I see the same behavior. no possibility to update, insert or delete the "evora" layer.

What is the format of the layer ? PostGIS, SHP, ??

#8 Updated by Giovanni Manghi over 6 years ago

Salvatore Larosa wrote:

I tested the service on both master and 1.8
and I see the same behavior. no possibility to update, insert or delete the "evora" layer.

What is the format of the layer ? PostGIS, SHP, ??

please try again,

I probably hit this issue #6798

while preparing the sample layer for the tinyows server.

#9 Updated by Salvatore Larosa over 6 years ago

Giovanni Manghi wrote:

Salvatore Larosa wrote:

I tested the service on both master and 1.8
and I see the same behavior. no possibility to update, insert or delete the "evora" layer.

What is the format of the layer ? PostGIS, SHP, ??

please try again,

I probably hit this issue

#6798

while preparing the sample layer for the tinyows server.

ok, on 1.8 works while on master only insert is not working

#10 Updated by Giovanni Manghi over 6 years ago

ok, on 1.8 works while on master only insert is not working

so now is probably the same is as qgis server (with postgis)?

#11 Updated by Giovanni Manghi over 6 years ago

ok, on 1.8 works while on master only insert is not working

weird, for is not working also update.

#12 Updated by Salvatore Larosa over 6 years ago

Giovanni Manghi wrote:

ok, on 1.8 works while on master only insert is not working

weird, for is not working also update.

my comment was not complete, sorry, update works changing a value in the attribute table but it doesn't after editing some geometries.

#13 Updated by Jürgen Fischer over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF