Bug report #7866

data-defined size for points layer wrongly computed when re-loading project

Added by Mathieu Pellerin - nIRV over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16741

Description

Steps to reproduce:
1. Open a new project
2. Load the attached test.shp file
3. Open the layer property, go to symbology section
4. Open the data defined property window, check the [ ] size box and use the "size" field
5. Apply, and notice how big the points are
6. Save this new project under any name
7. Close QGIS, re-open QGIS, re-load the newly saved project

At this stage, you'll notice the points' size is much smaller (i.e. wrong) than when layer was initially loaded and the size field set.

test.zip (1.28 KB) Mathieu Pellerin - nIRV, 2013-05-20 01:30 AM

Associated revisions

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

this is probably because of another bug not yet fixed in master, that makes the units be always map units by default, instead of mm. Please review the tracker and eventually close this as duplicate.

#2 Updated by Mathieu Pellerin - nIRV over 6 years ago

Giovanni, no, I don't think so. Switching from mm to map unit does make a difference (under proper value and "corrupted" re-loaded value). Give it a try.

#3 Updated by Giovanni Manghi over 6 years ago

Mathieu Pellerin - nIRV wrote:

Giovanni, no, I don't think so. Switching from mm to map unit does make a difference (under proper value and "corrupted" re-loaded value). Give it a try.

ok, anyway seems a regression, so tag this as blocker.

#4 Updated by Marco Hugentobler over 6 years ago

  • Status changed from Feedback to Closed

#5 Updated by Mathieu Pellerin - nIRV over 6 years ago

Marco, thanks.

Also available in: Atom PDF