Bug report #7856

after creating a wms/wcs/wfs/spatialite connection from toolbar, then QGIS browser does not do the refresh

Added by Giovanni Manghi over 6 years ago. Updated about 6 years ago.

Status:Closed
Priority:Normal
Assignee:Hugo Mercier
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16734

Description

... and the only way is closing and reopening QGIS.

This is a regression because for WMS/WFS/SL it used to work ok in QGIS 1.8.

It works for PostGIS connections also for master.

EDIT:
this happens only when there are no previous connections created, so I guess this is not really a blocker even if it is a (small) regression since 1.8

Associated revisions

Revision 71c9c36a
Added by Hugo Mercier about 6 years ago

Refs #7856. Fix model reference

Revision c77a48af
Added by Jürgen Fischer about 6 years ago

Merge pull request #737 from Oslandia/issue7856

Refs #7856. Fix model reference

History

#1 Updated by Salvatore Larosa about 6 years ago

it seems to work fine at the moment with the latest master.
(or at the least I am seeing the same behavior of 1.8)

Can you confirm it ?

#2 Updated by Giovanni Manghi about 6 years ago

  • Priority changed from Severe/Regression to Normal
  • Subject changed from after creating/deleting a wms/wcs/wfs/spatialite conection from toolbar, then QGIS browser does not do the refresh to after creating a wms/wcs/wfs/spatialite connection from toolbar, then QGIS browser does not do the refresh

Salvatore Larosa wrote:

it seems to work fine at the moment with the latest master.
(or at the least I am seeing the same behavior of 1.8)

Can you confirm it ?

just updated to the latest master, removed all the wms/wfs/wcs/sl connections, restarted QGIS, and this is what I see:

  • WMS:
  • I created a WMS connection, the browser (WMS/OWS) is not refreshed
  • Closing and reopening QGIS and the browser is refreshed, creating new WMS connections and the browser (WMS/OWS) refresh as expected
  • Deleting WMS connections and the browser refresh as expected

Result: the issue is only where there are NO other connections defined

  • WFS
  • if there are no other wfs connections available then the browser (WFS) is not refreshed, but if there are previous ows connections (from wms or wcs) then the OWS is refreshed
  • Closing and reopening QGIS and the browser is refreshed, creating new WFS connections and the browser (WFS/OWS) refresh as expected
  • Deleting WFS connections and the browser refresh as expected

Result: the issue is only where there are NO other connections defined

  • WCS

Same as above

  • SL

Same as above

#3 Updated by Hugo Mercier about 6 years ago

  • Assignee set to Hugo Mercier

Reproduced. Working on it.

#4 Updated by Hugo Mercier about 6 years ago

  • Status changed from Open to Resolved
  • Resolution set to fixed

#5 Updated by Daniel Vaz about 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF