Bug report #7850

Piled derived attributes in Identify Results

Added by Minoru Akagi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16731

Description

When more than one feature is identified by Identify Features tool, a feature sometimes has not only its own derived attributes but also other features'. Specifically, the second feature has the derived attributes of the first one. The third feature has the derived attributes of the above features.

It occurs in either cases:
- click on overlap part of overlap polygons
- click on between a point/line/polygon and the near feature

capture.png - a capture (87.6 KB) Minoru Akagi, 2013-05-17 04:31 AM

polygons.zip (1.05 KB) Minoru Akagi, 2013-05-17 04:50 AM

Associated revisions

Revision bdb2a4f1
Added by Matthias Kuhn over 6 years ago

Don't pile derived attributes (Fix #7850)

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

is this a regression since 1.8?

#2 Updated by Minoru Akagi over 6 years ago

Yes, no problem in 1.8.

#3 Updated by Minoru Akagi over 6 years ago

Added a set of test data.

#4 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Feedback to Open
  • Priority changed from Normal to Severe/Regression

#5 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

#6 Updated by Minoru Akagi over 6 years ago

Thank you! :)

Also available in: Atom PDF