Bug report #7821

opening GRASS raster properties causes crash

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:16706

Description

[email protected] ~ $ qgis
Warning: loading of qt translation failed [/usr/share/qt4/translations/qt_en_US]
Warning: Object::connect: No such signal QgsGrassRasterProvider::statusChanged( QString )
Fatal: QGIS died on signal 11
Stacktrace (run through c++filt):
/usr/bin/qgis.bin(Z15myMessageOutput9QtMsgTypePKc+0xac)[0x4e706c]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_Z17qt_message_output9QtMsgTypePKc+0x2e)[0x7fc727eef41e]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(+0x718bf)[0x7fc727eef8bf]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_Z6qFatalPKcz+0x94)[0x7fc727eefa64]
/lib/x86_64-linux-gnu/libc.so.6(+0x364a0)[0x7fc7253e04a0]
/usr/lib/libqgis_gui.so.1.9.0(_ZN20QgsOptionsDialogBase20restoreOptionsBaseUiEv+0x3de)[0x7fc7289ec51e]
/usr/bin/qgis.bin(_ZN24QgsRasterLayerPropertiesC1EP11QgsMapLayerP12QgsMapCanvasP7QWidget6QFlagsIN2Qt10WindowTypeEE+0x1d31)[0x6bac21]
/usr/bin/qgis.bin(_ZN7QgisApp19showLayerPropertiesEP11QgsMapLayer+0x281)[0x5121a1]
/usr/bin/qgis.bin[0x7abe7a]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN11QMetaObject8activateEP7QObjectPKS_iPPv+0x2b1)[0x7fc72800d281]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN7QAction9triggeredEb+0x32)[0x7fc727375132]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN7QAction8activateENS_11ActionEventE+0x6f)[0x7fc72737531f]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x617119)[0x7fc7277c7119]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x61d272)[0x7fc7277cd272]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x684)[0x7fc7273cc144]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN5QMenu5eventEP6QEvent+0x5b)[0x7fc7277ce80b]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xb4)[0x7fc72737b894]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0xabf)[0x7fc7273810bf]
/usr/lib/libqgis_core.so.1.9.0(_ZN14QgsApplication6notifyEP7QObjectP6QEvent+0x96)[0x7fc728eee6f6]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x8c)[0x7fc727ff8e9c]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN19QApplicationPrivate14sendMouseEventEP7QWidgetP11QMouseEventS1_S1_PS1_R8QPointerIS0_Eb+0x172)[0x7fc72737c862]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x24c2c1)[0x7fc7273fc2c1]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(_ZN12QApplication15x11ProcessEventEP7_XEvent+0xdce)[0x7fc7273fabae]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x2740d2)[0x7fc7274240d2]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_dispatch+0x133)[0x7fc723f0cd53]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(+0x480a0)[0x7fc723f0d0a0]
/lib/x86_64-linux-gnu/libglib-2.0.so.0(g_main_context_iteration+0x34)[0x7fc723f0d164]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0x6f)[0x7fc7280283bf]
/usr/lib/x86_64-linux-gnu/libQtGui.so.4(+0x273d5e)[0x7fc727423d5e]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x32)[0x7fc727ff7c82]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xf7)[0x7fc727ff7ed7]
/usr/lib/x86_64-linux-gnu/libQtCore.so.4(_ZN16QCoreApplication4execEv+0x87)[0x7fc727ffcf67]
/usr/bin/qgis.bin(main+0x228e)[0x4e302e]
/lib/x86_64-linux-gnu/libc.so.6(
_libc_start_main+0xed)[0x7fc7253cb76d]
/usr/bin/qgis.bin[0x4e6e11]
Aborted (core dumped)

curso_lisboa.tar.gz (1.03 MB) Giovanni Manghi, 2013-05-14 12:32 PM

History

#1 Updated by Radim Blazek over 6 years ago

I cannot reproduce it. Please try to find if it happens on all computers and try to narrow down conditions when it happens (raster type, reprojection...).

#2 Updated by Giovanni Manghi over 6 years ago

Radim Blazek wrote:

I cannot reproduce it. Please try to find if it happens on all computers and try to narrow down conditions when it happens (raster type, reprojection...).

Hi Radim, still crashes on my Linux Mint 64 bit with the latest master. Attached the location. I will test also on Windows. Thanks for looking into this.

#3 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Feedback

It does not crash here. Please try other computers.

#4 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

it works now with the latest master code. Thanks!

Also available in: Atom PDF