Bug report #7818

PostGIS warnings: Erroneous query: SELECT styleQML FROM layer_styles

Added by Matthias Kuhn over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Emilio Loi
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16703

Description

When adding a new postgis layer, I always get warnings in the message log saying

SELECT styleQML FROM layer_styles WHERE f_table_catalog=....
[ERROR: relation "layer_styles" does not exist]

I guess this is related to the possibility to save layer styles to the database.

Is this feature enabled by default? Are databases expected to contain a table "layer_styles"?

History

#1 Updated by Matthias Kuhn over 7 years ago

  • Status changed from Open to Closed

Seems to be fixed already.
Thank you jef.

38d63d1ac

#2 Updated by Emilio Loi over 7 years ago

I guess this is related to the possibility to save layer styles to the database.

You are right, it was my fault. When you add a postgis layer my code controls for a layer style saved in the database in "layer_styles" table. I forget to add a control on the table existence.
I was providing a patch, I'll merge my repo getting Jef patch.
Emilio

#3 Updated by Christophe Damour over 3 years ago

It seems that this error still occurs when adding a SpatiaLite layer.

Also available in: Atom PDF