Bug report #7806

"Invalid layer" dialog is not helpful

Added by Aren Cambre over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16696

Description

The Invalid Layer dialog does not explain why a layer is invalid.

The attached image has an Invalid Layer dialog that appeared after trying to add a PostGIS table. My view does not have an id column (it only has a geom column). If I didn't already know of the requirement for an id column, I would have had no clue what caused this error.

I am filing as a bug because this is a defect with the UI. The UI should explain errors in enough detail that the user can resolve them.

invalid_layer.png (23.9 KB) Aren Cambre, 2013-05-10 08:33 PM

Associated revisions

Revision 5009aad2
Added by Matthias Kuhn over 6 years ago

[Fix #7806] Be more verbose in "invalid layer" dialog

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF