Bug report #7802

"Join attributes by location" in qgis master has a memory leak and leads to crash

Added by Leonardo Gonnella over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:16694

Description

When i try to use "join attributes by location" in the Qgis Master version (OS Ubuntu 12.04) with the 2 attached's file, the process arrive near the 70-80%, then it appears a "python error" windows only for 1 second and the program crash.
I use the file "areestradali" as target vector layer, and the file "PericolositaSismica" as Join vector layer; I keep the other option as default.

I try also with Windows 8, and the program freeze near the 75% of the process and i have to kill the program..

PericolositaSismica.zip - join vector layer (457 KB) Leonardo Gonnella, 2013-05-10 10:05 AM

areestradali.zip - target vector layer (1.84 MB) Leonardo Gonnella, 2013-05-10 10:05 AM

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

does it works with qgis 1.8?

#2 Updated by Leonardo Gonnella over 7 years ago

Yes, it works with Qgis 1.8, both on Ubuntu and on Windows.

#3 Updated by Giovanni Manghi over 7 years ago

  • OS version deleted (12.04)
  • Priority changed from Normal to Severe/Regression
  • Operating System deleted (Ubuntu)

#4 Updated by Denis Rouzaud over 7 years ago

I could not reproduce on Ubuntu 12.04 / master 4e95496.

Everything went well with your data and setup.

#5 Updated by Giovanni Manghi over 7 years ago

  • Subject changed from Qgis Master crash when using "Join attributes by location" to "Join attributes by location" in qgis master has a memory leak and leads to crash
  • Status changed from Feedback to Open

Denis Rouzaud wrote:

I could not reproduce on Ubuntu 12.04 / master 4e95496.

Everything went well with your data and setup.

The difference of behaviour is because the tool has a memory leak: when you run it it starts eating up memory, if you have enough it will end (without releasing it), if not then it will lead to crash.

#6 Updated by Matthias Kuhn over 7 years ago

  • Status changed from Open to Closed
Fixed in 5cbfe07
Can you please verify that:
  • The tool works properly again
  • The memory leak issue is resolved

#7 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed

Matthias Kuhn wrote:

Fixed in 5cbfe07
Can you please verify that:
  • The tool works properly again
  • The memory leak issue is resolved

Hi Matthias,

does this commit fix also the memory leaks in the other affects tools in the vector menu?

cheers!

#8 Updated by Matthias Kuhn over 7 years ago

Well possible. It was in the OGR provider whenever a feature was requested with FilterFid.

#9 Updated by Leonardo Gonnella over 7 years ago

Hi all, i confirm that now it works, the memory leak is resolved.
Regards!

#10 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF