Bug report #7798

column filter does not work as expected

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16690

Description

open the attached sample vector and try to search in the table of attributes with the new column filter (column DESCRI) for the phrase

Montados de azinho com pastagem no subcoberto (<50%)

it won't work. But If you search just

Montados de azinho com pastagem no subcoberto

or

(<50%)

will work.

filter.zip (12.9 KB) Giovanni Manghi, 2013-05-10 02:57 AM

Associated revisions

Revision 4d3b1841
Added by Matthias Kuhn over 6 years ago

[Fix #7798] (I)LIKE operator escapes regexp characters before computing regexp

History

#1 Updated by Giovanni Manghi over 6 years ago

  • File deleted (filter.zip)

#2 Updated by Giovanni Manghi over 6 years ago

#3 Updated by Salvatore Larosa over 6 years ago

  • Assignee set to Matthias Kuhn

confirmed here on Linux.

Also, when it works, the dialog title is not refreshed!

#4 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

#5 Updated by Matthias Kuhn over 6 years ago

It's mostly fixed.
It was caused by a bug in QgsExpression, parsing a LIKE clause like a regexp.

It's still not possible to escape % and _ signs with the LIKE operator but now it the misbehavior is to match more rows instead of less rows. Followup opened here:
#7814

Also available in: Atom PDF