Bug report #7770

wmts tileset table emptied upon second getcap request

Added by Richard Duivenvoorde over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16666

Description

Add a wmts service url to the add wms dialog, eg:

http://geodata.nationaalgeoregister.nl/tiles/service/wmts/brtachtergrondkaart

And click 'connect', you will switch to the 'Tilesets' tab, and see the available layers for this service: imageOK

Then go back to the 'Layers' tab, and click 'connect' again (to receive getcaps again, don't know why you should do it, but I just did...)

You will be switched to the 'Tilesets', but now (in this case) the layer column seems to be filled ok, but all other columns are empty (except 3 rows in this case): imageNOK

53.png - imageOK (95.8 KB) Richard Duivenvoorde, 2013-05-05 10:42 PM

05.png - imageNOK (57.1 KB) Richard Duivenvoorde, 2013-05-05 10:42 PM

08.png - imageEmpty (23.8 KB) Richard Duivenvoorde, 2013-05-06 12:13 AM

Associated revisions

History

#1 Updated by Richard Duivenvoorde over 7 years ago

additionally another gui glitch, which is related I think

if you have connected to a wmts (so the Tilesets tab has been activated), but then connect to a WMS eg

http://geodata1.nationaalgeoregister.nl/luchtfoto/wms

the Tilesets tab seems still activated, but going to it , it is shown empty: imageEmpty

#2 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF