Bug report #7742

can't join table created with delimited text plugin

Added by Regis Haubourg over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Chris Crook
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16647

Description

Hi,
this is a regression, i can't join a table imported with new improved delimited text core plugin.

Table simply doesn't show up in table list in join tab.

Régis

History

#1 Updated by Chris Crook over 6 years ago

Thanks Régis.

It turns out I've already submitted a pull request https://github.com/qgis/Quantum-GIS/pull/569 that addresses this. Vector layers must implement subset strings in order to be available for joining. I wanted this capability for other reasons (visualisation of subsets) - joining to other tables was an accidental consequence!

I'm not sure if this is technically a regression, as I'm not sure if it was ever available as a capability (see comments in pull request).

#2 Updated by Chris Crook over 6 years ago

  • Pull Request or Patch supplied changed from No to Yes

#3 Updated by Regis Haubourg over 6 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Issue seems fixed to me. I close it, we need to start some cleanup on bug reports ;-)

#4 Updated by Regis Haubourg over 6 years ago

I forgot the most important thing: thanks !

Also available in: Atom PDF