Bug report #7721

GRASS v.db.addcolumn not working

Added by andre mano over 7 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GRASS
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16629

Description

With GRASS plugin, adding a column (v.db.addcolumn) to a vector point layer created through v.random does not change attribute table structure (even after removing the layer from QGIS TOC and reloading it again). Module returns the following message:

v.db.addcol [email protected] layer=1 "columns=MinDist DOUBLE PRECISION"

Database connection for map is not defined in DB file

There is no table connected to this map! Run v.db.connect or v.db.addtable first.
Finished with error

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Category set to GRASS

#2 Updated by Radim Blazek almost 5 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

v.random does not create table that is expected.

v.db.addcol fails if table does not exist, that is also expected.

v.db.addtable works for me.

Please reopen if necessary and specify which module exactly does not work and what error message it gives.

Also available in: Atom PDF