Bug report #770

lib64 support for x86_64 architectures

Added by silfreed-silfreed-net - almost 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Fedora Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10829

Description

In Fedora 64-bit libraries are installed to ${PREFIX}/lib64. Attached is a patch to relocate from lib/ to lib64/ using LIB_SUFFIX.

lib64-suffix-0.9.0.patch Magnifier - Patch to 0.9.0 for using LIB_SUFFIX to install/use different libdir (3.45 KB) silfreed-silfreed-net -, 2007-09-27 11:35 AM

History

#1 Updated by silfreed-silfreed-net - almost 13 years ago

See Red Hat Bug 247549 for details on my previous attempts to fix this bug.

#2 Updated by Martin Dobias almost 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Commits 1b4d9631 (SVN r7455) and 4364f124 (SVN r7457) made everything configurable, so now you should be able to modify QGIS_LIB_SUBDIR and QGIS_PLUGIN_SUBDIR variables in CMake to "lib64" and "lib64/qgis".

Martin

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.9.1 deleted

Also available in: Atom PDF