Bug report #7687

Query Builder Sample Restricted on Layer With Existing Query

Added by Spencer Gardner over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:16603

Description

If I make a definition query on a layer using the Query Builder, accept the changes, and then go back to the query builder to modify my existing query, the Sample function only shows a sample based on the existing query.

For example, if I query my existing countries layer for "Continent = 'Europe'" and then decide I want to also include "Continent = 'North America'", I can't get 'North America' to show up in the field sample; it only shows 'Europe'. I assume this is because the field sample reads off of the dataset using the active query. Ideally, the sample should include all values from the original dataset.


Related issues

Duplicates QGIS Application - Feature request #3337: Query Builder's data sampler doesn't use original dataset Closed 2012-06-30

History

#1 Updated by Jürgen Fischer over 6 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #3337

Also available in: Atom PDF