Bug report #7667

GRASS tools no more accessible on QGIS master

Added by Alessandro Ciali over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16584

Description

In the last master, GRASS modules are no more accessible neither from sextante nor from GRASS toolbar.
selecting a GRASS tool from GRASS toolbar produces the following error:

Cannot start module v.in.ogr
PATH=C:\\OSGeo4W\\apps\\Python27\\lib\\site-packages\\DLLs;C:\\OSGeo4W\\apps\\Python27\\DLLs;C:\\OSGeo4W\\apps\\grass\\grass-6.4.3RC2\\bin;C:\\OSGeo4W\\apps\\msys\\bin;C:\\OSGeo4W\\bin;C:\\Program Files (x86)\\Intel\\iCLS Client\\;C:\\Program Files\\Intel\\iCLS Client\\;C:\\Program Files (x86)\\NVIDIA Corporation\\PhysX\\Common;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\System32\\Wbem;C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\DAL;C:\\Program Files (x86)\\Intel\\Intel(R) Management Engine Components\\IPT;C:\\OSGeo4W\\apps\\msys\\bin;C:\\OSGeo4W\\apps\\Python27\\Scripts;C:\\OSGeo4W\\apps\\qgis-dev\\bin;C:\\OSGeo4W\\apps\\grass\\grass-6.4.3RC2\\lib
QGIS_PREFIX_PATH=C:/OSGeo4W/apps/qgis-dev
command: C:\\OSGeo4W\\apps\\grass\\grass-6.4.3RC2\\bin/v.in.ogr.exe --interface-description

From sextante, grass modules disappeared

screenshot.png (176 KB) Filipe Dias, 2013-04-21 03:14 AM

History

#1 Updated by Filipe Dias over 6 years ago

In Sextante you need to toggle "Advanced interface" to see Grass algs.

In Ubuntu, Grass 6.4.2 both are working fine. Maybe its related to your grass version being 6.4.3 rc2.

#2 Updated by Alessandro Ciali over 6 years ago

I can't find "advanced interface" on sextante,windows master, can you explain me where to find this option? It doesn't exist under sextante configuration win.

Latest win master comes with GRASS 6.4.3.RC2, that works fine with older master version installed some days ago

#3 Updated by Filipe Dias over 6 years ago

Low right corner, See the screenshot.

#4 Updated by Alessandro Ciali over 6 years ago

Thanks Pilipe, I got it. But the problem is still here: when selecting tools, a message appears telling that grass is not configured. I have checked out configuration, It seems to be ok. The same configuratio works whit previous version. I think the problem could be in the GRASS plugin.

#5 Updated by Giovanni Manghi over 6 years ago

Alessandro Ciali wrote:

Thanks Pilipe, I got it. But the problem is still here: when selecting tools, a message appears telling that grass is not configured. I have checked out configuration, It seems to be ok. The same configuratio works whit previous version. I think the problem could be in the GRASS plugin.

probably fixed with 6ee2d183696ae4c2be27350dd3519a9ba11b9a7b

this issue shows every time GRASS is updated in osgeo4w because after it is necessary to update the qgis/grass plugin.

#6 Updated by Alessandro Ciali over 6 years ago

updated Grass, Grass algorithms under sextante are workig now, but grass plugin has desappeared vron rhe plugin list. Any suggestion?

#7 Updated by Jürgen Fischer over 6 years ago

Giovanni Manghi wrote:

probably fixed with 6ee2d183696ae4c2be27350dd3519a9ba11b9a7b

No, GRASS 6.4.2RC3 was added today and will be picked up with the next nightly build - so this should only be an issue between the upload of GRASS and the next nightly build.

#8 Updated by Alessandro Ciali over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF