Bug report #7644

QGIS Server: Opacity not working in GetMap requests

Added by Andreas Neumann over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:16565

Description

Currently, the opacity values are ignored in GetMap requests:

here is a sample request:
http://webgis.uster.ch/wms/av/grundplan_av_farbig?LAYERS=Bodenbedeckung%20Fl%C3%A4che%20detailliert&OPACITIES=255&FORMAT=image%2Fpng%3B%20mode%3D8bit&DPI=96&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&SRS=EPSG%3A21781&BBOX=696329.11392406,245429.99701281,696623.41772152,245658.61058213&WIDTH=1017&HEIGHT=790

The image always appears with no transparency - regardless of the opacity value.

Thank you for having a look at this problem!

History

#2 Updated by Andreas Neumann over 7 years ago

The first link submitted should be with an opacity of 100 or so - sorry for posting the one link with 255

#3 Updated by Marco Hugentobler over 7 years ago

  • Status changed from Open to Feedback

Is this still true with current master? I cannot reproduce the bug with my local installation (unless it is something that only happens with special project configurations).

#4 Updated by Giovanni Manghi over 7 years ago

Marco Hugentobler wrote:

Is this still true with current master? I cannot reproduce the bug with my local installation (unless it is something that only happens with special project configurations).

I don't know if is related, but the transparency slider on QGIS web client does not work (anymore). Using a build from 23rd of May.

#5 Updated by Andreas Neumann over 7 years ago

  • Resolution set to worksforme

it seems to be fixed in the current master.

@Giovanni: I'll have a look at the client. The last version I used in production in Uster still works fine with the opacity slider.

I will have to test with the master version.

I'll close this bug now.

#6 Updated by Andreas Neumann over 7 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF