Bug report #7642

WMS had no image encoding enable when services only serves other then png

Added by Richard Duivenvoorde over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16563

Description

If you connect to a WMS service which serves it's layers in just one Image encoding, which is NOT image/png, there will be no Image encoding enabled when you click on one of the layers.

test: http://geodata1.nationaalgeoregister.nl/luchtfoto/wms

this service only serves as image/jpeg. Clicking on the available layer, the JPEG radio is not enabled (actually nothing is enabled). Now when you Add a layer, there is actually an error because QGIS requests images in image/png.

(fix will be attached)

Associated revisions

History

#2 Updated by Jürgen Fischer over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF