Bug report #7634

QGIS master crashes on Windows 7

Added by Antonio Locandro over 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:16556

Description

Every time I hit the Add Vector layer on an empty project it crashes after I hit the browse button, the work around is to create a new shapefile and then it works. No idea what this would happen but it shouldn't

qgis.log Magnifier - qgis-log-crash-debugview-20130417 (51.2 KB) Antonio Locandro, 2013-04-17 12:23 PM

qgis_log2.LOG Magnifier - QGIS log creating shapefile first (89 KB) Antonio Locandro, 2013-04-17 01:02 PM

qgis_log3.LOG Magnifier - restarting QGIS in same windows session after doing previous step (64.4 KB) Antonio Locandro, 2013-04-17 01:02 PM

History

#1 Updated by Giovanni Manghi over 7 years ago

if confirmed this must me tagged as blocker, thanks!

#2 Updated by Jürgen Fischer over 7 years ago

not reproducable here.

#3 Updated by Antonio Locandro over 7 years ago

I am using OSGEO4W to install, if not reproducable on your parte Jurgen do you know what should I do to fix my installation?

#4 Updated by Jürgen Fischer over 7 years ago

Antonio Locandro wrote:

I am using OSGEO4W to install, if not reproducable on your parte Jurgen do you know what should I do to fix my installation?

Not really, but DebugView might produce output sheds some light.

#5 Updated by Antonio Locandro over 7 years ago

Ok so I used the Debugview, but have absolutely no clue what to look for so I attached the log maybe someone with a keen eye can help

#6 Updated by Jürgen Fischer over 7 years ago

Antonio Locandro wrote:

Ok so I used the Debugview, but have absolutely no clue what to look for so I attached the log maybe someone with a keen eye can help

Thanks, unfortunately nothing stands out. I suppose a log from a run with creating a shapefile before the hitting "browse" would also show anything useful. Do you have mapped network drives or any other special disk devices - or maybe recently removed any?

#7 Updated by Antonio Locandro over 7 years ago

Ok qgis_log2 is creating first the shapefile, then it works ok
qgis_log3 is opening master again and just hit the add vector dialog then it works ok

It seems to be random crash after you create a shapefile, sometimes it works sometimes it crashes.

I do have do folders mapped as networks but do no work on them with QGIS for now

#8 Updated by Jürgen Fischer over 7 years ago

Try without any third party plugins, please.

#9 Updated by Antonio Locandro over 7 years ago

Just letting you know it apparently works ok now, no problems for the last 2 days

#10 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

reopen if necessary.

Also available in: Atom PDF