Bug report #7606

"Update options" doesn't work in DBManager if the input dropdown menu has never been touched

Added by Emilio Loi over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16534

Description

In DBManager try to import a vector layer. The "Input" dropdown menu shows, as first choice, a vector layer name that's loaded in the project. If the dropdown menu has never been touched, clicking on "Update options" button causes a log message "Data source is invalid" because no layer has been selected.

dbm.png (47.1 KB) Emilio Loi, 2013-04-14 03:11 AM

Associated revisions

Revision cb1e47be
Added by Giuseppe Sucameli over 7 years ago

DBManager: fix 'Update Option' button behaviour (fix #7606)

History

#1 Updated by Giuseppe Sucameli over 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF