Bug report #760

QGIS crashes when Postgis Layer GeometryType doesn't correspond with geometry_columns definition

Added by horst-duester - about 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gavin Macaulay -
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10819

Description

QGIS crashes when I load a PostGIS Layer with wrong geometry type definition in geometry_columns.

1. Define Layer in geometry_columns with geometry type POLYGON
2. create a layer with geometry type LINESTRING
3. load this layer
4. QGIS crash

History

#1 Updated by Gavin Macaulay - almost 13 years ago

  • Status changed from Open to In Progress

#2 Updated by Gavin Macaulay - almost 13 years ago

Works for me with aca333fe (SVN r7323). Can you try again, and if it still occurs give some more details on the problem?

#3 Updated by horst-duester - almost 13 years ago

It seems to be solved. I can't reproduce this error too. I think we can close this ticket.

#4 Updated by Gavin Macaulay - almost 13 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Seems to have been fixed.

#5 Updated by Anonymous about 11 years ago

Milestone Version 0.9.1 deleted

Also available in: Atom PDF