Bug report #7588

wfs client crashes if url is wrong

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:16521

Description

what does happen if I make a genuine mistake can I copy/paste the wrong url when creating a wfs connection:

"unexpected character"

then crash

Warning: Object::connect: No such signal QgsVectorLayerCache::finished()
Warning: Object::connect: (receiver name: 'mMainView')
Warning: QLayout: Cannot add null widget to QVBoxLayout/mAttributeEditorLayout
Warning: QMetaObject::connectSlotsByName: No matching signal for on_treeWidget_itemDoubleClicked(QModelIndex)
Warning: QMetaObject::connectSlotsByName: No matching signal for on_treeWidget_currentRowChanged(QModelIndex,QModelIndex)
Warning: QMetaObject::connectSlotsByName: No matching signal for on_mBuildQueryButton_clicked()
Segmentation fault

I noticed while making a genuine mistake and pasting this url

http://mapas.igeo.pt/igp/wfs_sig.html

instead of one of the wfs services listed on the same page.

Associated revisions

Revision b7c07def
Added by Laurent Defert over 6 years ago

Always delete WFS network replies, fixes #7588

Revision 91eaa415
Added by Marco Hugentobler over 6 years ago

Merge pull request #632 from BioEcoForests/master

Always delete WFS network replies, fixes #7588

History

#1 Updated by Giovanni Manghi over 6 years ago

it crashes also if it just goes in timeout.

#2 Updated by Laurent Defert over 6 years ago

Hello,

I cannot reproduce the crash, I think it may have been fixed with the patch I submitted for #7913, can you confirm ?
Though, the error messages should be changed imho to make them more user-friendly (the "unexpected character" and "Operation canceled" when a timeout occurs).
Anyway, here, it's not crashing, but it seems the connection thread is not cleaned properly. Even after closing the wfs client dialog, I'm getting every 20s a new entry in the network log about the timeout (though no connection attempt is made as I can see with tcpdump). Should I open a new ticket for this issue or is it ok to continue on this ticket ?

#4 Updated by Marco Hugentobler over 6 years ago

  • Status changed from Open to Closed

#5 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed

Laurent Defert wrote:

Hello,

I cannot reproduce the crash, I think it may have been fixed with the patch I submitted for #7913, can you confirm ?

correct

Also available in: Atom PDF