Bug report #7543

Dual View Table/Form: Preview column not saved in project

Added by Andreas Neumann over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16486

Description

When selecting a preview column in the form view of the dual view table/form, the selected preview column is not saved/loaded in the project. After a project reload, the column selection is lost.

Associated revisions

Revision 57c23078
Added by Matthias Kuhn over 6 years ago

[FIX #7543] Dual View Table/Form: Preview column not saved in project

History

#1 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Feedback

I agree, this needs to be saved. I didn't do this yet, because I wasn't sure of the best way and therefore forgot about this.

Explanation: The default choice of this field is chosen by the "Map Tip display text" from the layer properties -> Display definition (and from the primary key as a second choice).
So when the preview column is changed, would you also expect the "Map Tip display text" to change? These two are both used as human-readable identifier strings for features. If you would also want this to change, the "Map Tip display text" there is the problem, that the "preview column" of the dual view is based on QgsExpression, while the "Map Tip display text" is based on a) a field or b) HTML (with optional embedded expressions).

So, the question is, when changing the preview column, would you
- save this independently from the "Map Tip display text"
- somehow synchronize these two? (E.g. replace the "Field" of "Map Tip display text" with "Expression", only set the "Map Tip display text" if not yet customized by the user... Further inputs welcome)

#2 Updated by Andreas Neumann over 6 years ago

Hi Matthias,

I think they should be independent.

I use the map tips often with HTML code (e.g. tables, sometimes even containing image URLs, interactive content, etc.) - since these map tips are used to display the essende of the selected object and are also used in QGIS web client. The map tips would be too complex in this case to be used as a human-readable identifier.

In reality, I would often use the expression to combine a human-readable object name with the pkey in parenthesis. Or sometimes theres is a unique human-readable column next to the pkey which I can choose.

So please make this independent from the map tips.

Ideally, the preview column would also be sorted. I know that one can sort the column in the table and it is reflected, but it would be nice if also in the form view there would be a way to sort the preview column or expression without the need to switch back and forth to the table view.

Thanks,
Andreas

#4 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Feedback to In Progress

#5 Updated by Matthias Kuhn over 6 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF