Bug report #7536

shapefiles served with qgis wfs server are completely wrong (used to work in 1.8)

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:René-Luc ReLuc
Category:Web Services clients/WFS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16480

Description

pick the attached sample project, and change the project settings ("ows server") so you will able to publish it with qgis server (wfs).

Then use the qgis wfs client to download the vector, you will see (see attached images) that is completely wrong.

This does not happen if the input vector is PostGIS and didn't happened at all on qgis 1.8.

51.png - right (445 KB) Giovanni Manghi, 2013-04-07 03:49 AM

10.png - wrong (601 KB) Giovanni Manghi, 2013-04-07 03:49 AM

wfs.zip (279 KB) Giovanni Manghi, 2013-04-07 03:49 AM

History

#1 Updated by René-Luc ReLuc over 6 years ago

  • Category changed from QGIS Server to Web Services clients/WFS

I have testing the project and comparing GML and GeoJSON provided by the QGS Server WFS.

The GeoJSON rendering is exactly the same as ESRI ShapeFile.
The GML data is the same as GeoJSON but the rendering is not the same.

The problem is a GML Parsing error.

#2 Updated by René-Luc ReLuc over 6 years ago

  • Resolution set to fixed
  • % Done changed from 0 to 100
  • Assignee set to René-Luc ReLuc
  • Status changed from Open to Closed

The bug was due to an inversion between tuple and coordinates separator in Polygon coordinates elements.

commit 28ade759b32bee140356081607d86814b25a755f 28ade759b32bee140356081607d86814b25a755f

Also available in: Atom PDF