Bug report #7521

QGIS mapserver not working in compliance with SLD spec for GetLegendGraphic requests

Added by Marco Lechner over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:High
Assignee:Marco Hugentobler
Category:QGIS Server
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16468

Description

QGIS mapserver expects layers and styles transmitted as LAYERS and STYLES parameter on GetLegendGraphic requests (WMS 1.1.1). WMS specs reference SLD specs. On page 62 (pdf page 72) of SLD 1.0 OGC 02-070 http://portal.opengeospatial.org/files/?artifact_id=1188 the parameters for GetLegendGraphic request have to be LAYER and STYLE instead of plural. Similar to GetLegendGraphics/GetLegendGraphic QGIS mapserver could easily respect both (at the moment it breakes the spec) by applying the attached patch. Patch is similar as bugfix for QGIS 1.8, no changes in function since then, just different linenumbers.
This behaviour causes internal server error when a client requests in compliance to the specs.
Affected versions master and before (1.8.0, may be earlier)

QGISmapserverGetLegendGraphic_3.patch Magnifier - bug in last patch (1.46 KB) Marco Lechner, 2013-04-05 02:18 PM

History

#1 Updated by Marco Lechner over 6 years ago

  • File deleted (QGISmapserverGetLegendGraphic.patch)

#2 Updated by Marco Lechner over 6 years ago

  • File QGISmapserverGetLegendGraphic_2.patch added

patch now also tests for mandatory params for GetLegendGraphic (FORMAT, LAYER)

#3 Updated by Marco Lechner over 6 years ago

  • File deleted (QGISmapserverGetLegendGraphic_2.patch)

#5 Updated by Giovanni Manghi over 6 years ago

adding the patch on github has a better chance to be reviewed and added sooner that later.

#6 Updated by Marco Lechner over 6 years ago

  • Status changed from Open to Closed

patch commited by jef-n into master d62d88ed03cb0b2008c28bc6bdc2c50d73e30f5a

Also available in: Atom PDF