Bug report #7469

Delete records in qgis master is very slow (was quick on 1.8)

Added by Luca Lanteri over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16422

Description

On qgis master (1.9-93ade1f) The delete selected features on table view doesn't work. Nothing happens when push it.

History

#1 Updated by Werner Macho over 6 years ago

Not confirmed here ..
Can you describe what you did and with what data you were working?

#2 Updated by Pedro Venâncio over 6 years ago

I also do not confirm, on Linux.

But I notice a huge regression in the time it takes to delete records.

In a quick test, I arrived at these results, deleting 600 records from a points layer:

- QGIS 1.8: almost instantaneous;
- QGIS Master: ~77s. It looks like delete one by one.

Anyone confirms?

#3 Updated by Luca Lanteri over 6 years ago

I also do not confirm the first problem (it could be a my local PC problem), but I confirm the regression in deleting records.

#4 Updated by Giovanni Manghi over 6 years ago

  • Category set to Vectors
  • Subject changed from Delete selected features doesn't work to Delete records in qgis master is very slow (was quick on 1.8)

#5 Updated by Giovanni Manghi over 6 years ago

I think that in the very latest master code there was an improvement, but still slower than 1.8

#6 Updated by Pedro Venâncio over 6 years ago

Giovanni Manghi wrote:

I think that in the very latest master code there was an improvement, but still slower than 1.8

I just try with master compiled today and the same 600 records that yesterday took 77s, today disappear instantly!

#7 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

Pedro Venâncio wrote:

Giovanni Manghi wrote:

I think that in the very latest master code there was an improvement, but still slower than 1.8

I just try with master compiled today and the same 600 records that yesterday took 77s, today disappear instantly!

Matthias committed big changes in this compartment, expected improvement also for table selections, to be tested.

Can we close this?

#8 Updated by Pedro Venâncio over 6 years ago

  • Status changed from Feedback to Closed

Yeah, I'm noticing quite a few improvements in the performance of interaction with the attribute table.

Yes, I think we can close this ticket.

Thanks!

Also available in: Atom PDF