Bug report #7464

Removing 1 subgroup from legend in print composer removes 2 subgroups

Added by ramon . over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16419

Description

Today I needed to remove a subgroup of items from a legend in a print composer.
I selected the layer title from the list, clicked the minus button and the subgroup and next subgroup below are removed.

Confirmed for win7 (87265c7, 93ade1f) and mac (0005467) installs but probably more widespread.
http://lists.osgeo.org/pipermail/qgis-developer/2013-March/025060.html

Associated revisions

Revision 1dc75dd6
Added by Nathan Woodrow over 6 years ago

Fix removing composer legend items. Fix #7874 Fix #7464

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Priority changed from Normal to Severe/Regression

It is a regression since in 1.8 worked as expected.

#2 Updated by Etienne Tourigny over 6 years ago

  • Subject changed from Removing 1 subgroup from legend removes 2 subgroups to Removing 1 subgroup from legend in print composer removes 2 subgroups

#3 Updated by Anonymous over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF