Bug report #7423

"check geometry validity" crashes qgis

Added by Giovanni Manghi over 6 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:16386

Description

When using sextante, if a vector output is saved as a shape (in opposition to the choice to let sextante create a temp file) it can be automatically be added to the project at the end of the operation. This is added to the legend with the username plus the .shp extension.

if I run the "check geometry validity" on this layer, qgis crashes. If I add this layer as usual, and try the tool then qgis does not crash.

Tested on master/windows.

EDIT:
it does not seems the above case, it happens often when I have a bunch of layers loaded, regardless the origin. If I open again qgis and load the layer, the tool work ok.

inter.zip (875 KB) Giovanni Manghi, 2013-03-22 10:27 AM

History

#1 Updated by Giovanni Manghi over 6 years ago

it does not seems to be a rule... anyway you can try the attached vectors and do with sextante a "polygon intersection".

#2 Updated by maning sambale over 6 years ago

@Giovanni Manghi, I cannot reproduce the crash using you inter.zip data. Everything worked as expected. I have several data loaded both from the temp layers created by Sextante and other sources.

System: Ubuntu precise latest nightly build.

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

I cleaned my installation by deleting the Quantum Gis folder in .config and now I'm not able to get the crash anymore.

#4 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF