Bug report #7422

"check geometry validity" never ends

Added by Giovanni Manghi over 6 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16385

Description

with the attached shapefile the tool does nothing. tested on master/windows.

attach.zip (840 KB) Giovanni Manghi, 2013-03-22 09:47 AM

History

#1 Updated by vinayan Parameswaran over 6 years ago

It worked for me in Windows master. It took around 3 minutes to process the first feature(probably the one with a lot of holes) without any update to progress. Then it updated the progressbar well to complete in around 3.5 minutes.

#2 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

correct, now it works. Probably something was fixed along the way.

#3 Updated by Giovanni Manghi over 2 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF