Bug report #7393

wms identify in "feature" format does not show attributes

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16364

Description

try

http://mapas.igeo.pt/wms/clc

the result window is an in the attached image.

The getfeatureinfo url is

http://mapas.igeo.pt/wms/clc?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetFeatureInfo&BBOX=-21113.5710790909433854,-57357.4194735628916533,2457.0730308950028302,-46663.3309421803787700&SRS=EPSG:3763&WIDTH=756&HEIGHT=343&LAYERS=CLC06_PT&STYLES=&FORMAT=image/png&QUERY_LAYERS=CLC06_PT&INFO_FORMAT=application/vnd.ogc.gml&X=380&Y=247&FEATURE_COUNT=10

and return the attributes

<msGMLOutput xmlns:gml="http://www.opengis.net/gml" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<CLC06_PT_layer>
<CLC06_PT_feature>
<gml:boundedBy>
<gml:Box srsName="EPSG:3763">
<gml:coordinates>
-9825.903200,-54690.441800 -8679.891600,-53982.945300
</gml:coordinates>
</gml:Box>
</gml:boundedBy>
<OBJECTID>32201</OBJECTID>
<ID>PT-32201</ID>
<CODE_06>112</CODE_06>
<ORIG_FID>3384</ORIG_FID>
<AREA_HA>49.534</AREA_HA>
</CLC06_PT_feature>
</CLC06_PT_layer>
</msGMLOutput>

2013-03-19-083430_1024x600_scrot.png (109 KB) Giovanni Manghi, 2013-03-19 01:36 AM

History

#1 Updated by Radim Blazek over 6 years ago

Works for me, can you verify?

#2 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Feedback

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

seems to work now. Thanks!

Also available in: Atom PDF