Bug report #7386

Editable status of field widget not stable

Added by Andreas Neumann over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16357

Description

In the field widget definitions one can set if a widget is editable.

Unfortunately this setting does not remain as the user entered it, for some reason.

If one changes a widget to "not editable", does some changes to widgets of other fields, closes the dialog, opens it again and looks in the widget definition the editable state of the field changes back to "editable".

There seems to be a problem with the dialogues storing/loadin/displaying these values.

Associated revisions

Revision 981c174f
Added by Jürgen Fischer over 8 years ago

fix #7386 (another issue)

Revision 9672d1f7
Added by Jürgen Fischer over 8 years ago

fix #7386 (yet another issue)

History

#1 Updated by Jürgen Fischer over 8 years ago

  • Status changed from Open to Closed

#2 Updated by Salvatore Larosa over 8 years ago

it still occurs here.

steps to replicate:

*set a field to not editable (unchecked)
*apply
*set another field to not editable (unchecked)
*apply

oddly the first field is now editable.

#3 Updated by Giovanni Manghi over 8 years ago

reopen the ticket?

#4 Updated by Salvatore Larosa over 8 years ago

  • Status changed from Closed to Reopened

#5 Updated by Denis Rouzaud over 8 years ago

I cannot reproduce last bug:

*set a field to not editable (unchecked)

*apply

*set another field to not editable (unchecked)

*apply

oddly the first field is now editable.

I tried with postgis and shapefiles.

#6 Updated by Andreas Neumann over 8 years ago

It seems to work fine for me now. From my point of view we can close this bug if Salvatore is also ok with it? Salvatore - did you test with the latest version?

Thanks Jürgen for fixing it!

Andreas

#7 Updated by Salvatore Larosa over 8 years ago

unfortunately it doesn't work as expected here (unless I am wrong).
the link shows a short video on what happens to me (following the above steps)

http://lrssvt.ns0.it/img/enableStatus.ogv

#8 Updated by Jürgen Fischer over 8 years ago

  • Status changed from Reopened to Closed

#9 Updated by Salvatore Larosa over 8 years ago

  • Status changed from Closed to Reopened

Sorry if I am opening again this issue, but
I still getting some strange thing after the latest fix.

It seems that if I set to not editable a field
even all the others fields are not editable.

#10 Updated by Denis Rouzaud over 8 years ago

First, thanks Jef for the first two fixes, you were a lot quicker than me.

Also, Salvatore, do you have a step-by-step procedure to the last problem. I can't reproduce it.

#11 Updated by Salvatore Larosa over 8 years ago

Denis Rouzaud wrote:

Also, Salvatore, do you have a step-by-step procedure to the last problem. I can't reproduce it.

Hi Denis,
you can reproduce it adding a new layer (shp or DB) into your project and set a field to not editable
Finally try to insert a new feature or simply open the edit form from identify result.

http://lrssvt.ns0.it/img/editableStatus2.ogv

#12 Updated by Jürgen Fischer over 8 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF