Bug report #7298

Intersect strange results

Added by Stephane Goldstein over 7 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System:Windows Easy fix?:
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16300

Description

Hi.

I was intersecting lines with polygons and was getting strange results.

I used the exact same procedure in QGIS 1.8 and in QGIS 1.9

It works perfectly in 1.8.

In QGIS 1.9 the lines are splitted, but some of them don't take the attributes from the right polygon.

Here on QGIS 1.8: http://tinypic.com/r/3586grd/6

Here on QGIS 1.9: http://tinypic.com/r/swbmvo/6

The files used and the results are attached.

intersct_qgis_1.9_bug.zip (91.4 KB) Stephane Goldstein, 2013-03-09 12:16 PM

Associated revisions

Revision 6088fd71
Added by Minoru Akagi over 7 years ago

fTools: fix geoprocessing (fix #7298)

History

#1 Updated by Minoru Akagi over 7 years ago

I'm sorry. I had forgotten to put a link.
There is a pull request to fix this issue: https://github.com/qgis/Quantum-GIS/pull/713

#2 Updated by Minoru Akagi over 7 years ago

  • Status changed from Open to Closed

#3 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF