Bug report #7253

save problem on units DegreesMinutesSeconds

Added by wayne wang over 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:16274

Description

when set "Layer units" of "Project properties" to "Degrees, Minutes, Seconds" and save the project ,
the "unit" setting of the project file changes to "unknown".

psw : it's because the methods "writeXml() and "readXml()" in "src/core/qgsmaprender.cpp" lack operation for QGis::DegreesMinutesSeconds.

dms.patch Magnifier - patch for src/core/qgsmaprender.cpp (618 Bytes) wayne wang, 2013-03-06 12:25 AM

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Status changed from Open to Feedback
  • Category set to Project Loading/Saving

Please submit a patch. cheers!

#2 Updated by wayne wang over 8 years ago

see attachment.

#3 Updated by Giovanni Manghi over 8 years ago

  • Pull Request or Patch supplied changed from No to Yes

wayne wang wrote:

see attachment.

to raise the chance to see this patch reviewed and applied it would be better to submit it as pull request on github

https://github.com/qgis/Quantum-GIS/pulls

#4 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

does not happen on qgis master, so it should have been fixed along the way since qgis 1.8

Also available in: Atom PDF