Bug report #7240

Copy and Paste of Features does not work

Added by Andreas Neumann over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16268

Description

When copying and pasting features from one layer to another nothing happens.

Maybe a problem of the new Vector API?

Tested on Windows (OSGeo4W - recent nightly build) with Postgis layers and line geometries.

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

It works here on master/ubuntu. Can you a sample? cheers!

#2 Updated by Andreas Neumann over 6 years ago

Hi Giovanni,

Did you also test with 2 Postgis Layers or just with shapes or spatialite?

Andreas

#3 Updated by Giovanni Manghi over 6 years ago

Giovanni Manghi wrote:

It works here on master/ubuntu. Can you add a sample? cheers!

#4 Updated by Giovanni Manghi over 6 years ago

Andreas Neumann wrote:

Hi Giovanni,

Did you also test with 2 Postgis Layers or just with shapes or spatialite?

Andreas

I will test postgis and report back (tested shapes and SL). cheers

#5 Updated by Jürgen Fischer over 6 years ago

Giovanni Manghi wrote:

Giovanni Manghi wrote:

It works here on master/ubuntu. Can you add a sample? cheers!

Works for me with two postgis line layers, too. Anything special about your layers? I just d&d one line layer from one user to another, clean it, and then copied some features - apparently worked fine.

#6 Updated by Andreas Neumann over 6 years ago

ok - I have to test again tomorrow at work. I don't have the project with me. Thank you both for testing!

Andreas

#7 Updated by Andreas Neumann over 6 years ago

  • Resolution set to invalid

Turned out that it is my fault. A layer filter prevented it to display the feature. Sorry about the fusss!

#8 Updated by Andreas Neumann over 6 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF