Bug report #7238

Identify does not work anymore in qgis server master

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Radim Blazek
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16266

52.png (625 KB) Giovanni Manghi, 2013-02-26 02:01 AM

28.png (238 KB) Giovanni Manghi, 2013-02-26 02:01 AM

Associated revisions

Revision 173aee6e
Added by Radim Blazek over 6 years ago

WMS GetFeatureInfo supported formats fix, fixes #7238

History

#1 Updated by Matthias Kuhn over 6 years ago

Issue #7258 is probably related

#2 Updated by Marco Hugentobler over 6 years ago

  • Assignee set to Marco Hugentobler

#3 Updated by Marco Hugentobler over 6 years ago

  • Assignee changed from Marco Hugentobler to Radim Blazek
  • Category changed from QGIS Server to Web Services clients/WMS

This is a client problem. GetFeatureInfo from browser works normally.
The problem is that QGIS now prefers the output format text/xml. However, if the xml is not gml, the WMS client does not do anything with it (quite understandable, the output form of GetFeatureInfo is left to the server according to the WMS spec).

#4 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Closed

#5 Updated by Radim Blazek over 6 years ago

It should be fixed.

Now you should get with QGIS mapserver optional (combo in identify results) text and html format.

Also available in: Atom PDF