Bug report #7226

All attempts to specify a project, layer or default coordinate reference system (CRS)from any available menu or dialog box causes QGIS to crash

Added by Charles Petersen over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:1.8.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:16257

Description

All attempts to specify a project, layer or default coordinate reference system (CRS)from any available menu or dialog box causes QGIS to crash, even after all plug-ins have been disabled.

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback

try (backup) and remove the .qgis folder.

What is the attached .exe file?

#2 Updated by Charles Petersen over 7 years ago

Thanks for the feedback. I moved the .qgis folder to a flash drive,d restarted QGIS, and attempted to specify a CRS but the program crashed again.
Here is the error message from Win 7:

Problem signature:
Problem Event Name: APPCRASH
Application Name: qgis.exe
Application Version: 0.0.0.0
Application Timestamp: 4fdce845
Fault Module Name: QtCore4.dll
Fault Module Version: 4.7.1.0
Fault Module Timestamp: 4d530715
Exception Code: c0000005
Exception Offset: 000025bf
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

I have no idea what the attached file is. I thought I was attaching QGIS.exe, but maybe the above information is more useful.

#3 Updated by Giovanni Manghi over 7 years ago

  • File deleted (nircmd.exe)

#4 Updated by Giovanni Manghi over 7 years ago

try re-installing the program?

something seems wrong with

Fault Module Name: QtCore4.dll

#5 Updated by Charles Petersen over 7 years ago

I will reinstall the program, although I must say I have already done that. I assume that QtCore4.dll is a QGIS module.

#6 Updated by Giovanni Manghi over 7 years ago

Charles Petersen wrote:

I will reinstall the program, although I must say I have already done that. I assume that QtCore4.dll is a QGIS module.

seems anyway a local issue, try see if you other copies of that library around in your system.

#7 Updated by Charles Petersen over 7 years ago

I think you might be right. I will check for the .qgis folder elsewhere in my system. Right now, however, I'm reinstalling QGIS

#8 Updated by Charles Petersen over 7 years ago

I looked for other .qgis folders on my entire 1TB hard drive, but found none. After confirming that there was no .qgis folder in the directory where it is normally found, I reinstalled QGIS, and then ran the program without installing any additional plugins other than the ones available through the basic installation. Once again, unfortunately, it crashed when I tried to specify a CRS. The error message pointed to the same fault module (QtCore4.dll). If the problem is local, it doesn't look like it has anything to do with the .qgis folder.

#9 Updated by Giovanni Manghi over 7 years ago

Charles Petersen wrote:

I looked for other .qgis folders on my entire 1TB hard drive, but found none. After confirming that there was no .qgis folder in the directory where it is normally found, I reinstalled QGIS, and then ran the program without installing any additional plugins other than the ones available through the basic installation. Once again, unfortunately, it crashed when I tried to specify a CRS. The error message pointed to the same fault module (QtCore4.dll). If the problem is local, it doesn't look like it has anything to do with the .qgis folder.

look for other QtCore4.dll copies. the .qgis folder is just one and does not contain that library.

#10 Updated by Giovanni Manghi about 7 years ago

  • Subject changed from CRS Specification to All attempts to specify a project, layer or default coordinate reference system (CRS)from any available menu or dialog box causes QGIS to crash

#11 Updated by Jürgen Fischer almost 7 years ago

  • Priority changed from High to Normal

#12 Updated by Matthias Kuhn over 6 years ago

Is this still an issue for somebody?

#13 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF