Bug report #7169

qgis master messes up table of attributes when deleting columns

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Matthias Kuhn
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16221

Description

Open a shape in both qgis 1.8 and master.

Toggle editing and from the table of attributes dialog hit the "delete columns" button, then choose one ore more columns that are not at the end of the table.

In QGIS 1.8 it works more or less ok, the columns are correctly deleted, a minor issue is that when you hit save the columns after the deleted ones become all full of "nulls", but closing and reopening the table fixes it.

In QGIS master when you delete columns that are not at the end of the table things get messed, usually the result is that one od the selected columns is not deleted and another one (not selected) is deleted instead.


Related issues

Related to QGIS Application - Bug report #7190: Cell values in attribute table aren't refreshed after col... Closed 2013-02-20

History

#1 Updated by Amit Kulkarni over 6 years ago

I could not replicate this. By open a shape, you mean shapefile?

#2 Updated by Borys Jurgiel over 6 years ago

Confirmed when removing multiple columns at once.
For example: try to remove first two columns. Actually 1st and 3rd is going to be removed.
In general, seems if I remove columns number n and m, then columns n and (m+1) are removed.

#3 Updated by Borys Jurgiel over 6 years ago

See also #7190

#4 Updated by Matthias Kuhn over 6 years ago

  • Assignee set to Matthias Kuhn

Is caused by attributes not being a map, but a list and removal in ascending order...

#5 Updated by Matthias Kuhn over 6 years ago

Pull request #431 will fix this.
In case the pull request gets rejected, cherry picking commit:d83f764 should work as well.

#6 Updated by Matthias Kuhn over 6 years ago

  • Status changed from Open to Closed

Pull request got accepted.
Fixed in 0d3a3879

Also available in: Atom PDF