Bug report #7166

raster resampling does not work when reprojection is on.

Added by Giovanni Manghi over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16219

Description

Happens even if the raster is not actually reprojected, is just enough to have OTFR on. Tested on QGIS master.

As a new feature not working as should be, I tag this as blocker.

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Subject changed from resampling does not work for reprojected rasters to raster resampling does not work when reprojection is on.

#2 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Feedback

Works for me. Both if reprojection is on and raster is not reprojected and if raster is reprojected.

Note that resampling is done before reprojection. If source and target CRS are very different, it may happen that resampling effect is lost because neighbour pixel in target are not neighbour in source. I would call this feature, at least for now (2.0).

#3 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

#4 Updated by Radim Blazek over 6 years ago

There were some bugs in resampler. If oversampling was 1, it was not doing resampling and returning smaller block (by 1 row,col) than requested. That could result in completely distorted raster and zoomed in resampler was never used with reprojection because reprojector limits resolution exactly to raster resolution. It should be fixed in 36bf93c.

Also available in: Atom PDF