Bug report #7135

QGIS on getFeatureInfo wrong GML request

Added by aperi2007 - almost 9 years ago. Updated almost 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:16202

Description

Hi,

qgis-dev is doing a wrong GML request on GetFeatureInfo.

I see the request is doing qgis is this:

http://web.regione.toscana.it/wmsraster/com.rt.wms.RTmap/wms?map=wmsambamm&map_resolution=96&language=ita&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&BBOX=41.9051649201365208,7.9059189999999990,44.7788350798634838,14.1706910000000015&CRS=EPSG:4326&WIDTH=1465&HEIGHT=672&LAYERS=rt_ambamm.idcomuni.rt.poly&STYLES=&FORMAT=image/png&QUERY_LAYERS=rt_ambamm.idcomuni.rt.poly&INFO_FORMAT=ogr/gml&I=691&J=315&FEATURE_COUNT=10

But it is wrong because it is doing the request in EPSG:4326 instead of the actual EPSG used in the canvas.
This cause the return of a GML in a wrong reference system (4326). Wrong because it is not in the right wanted reference system.

Also another error is that the request is do setting:

INFO_FORMAT=ogr/gml

instead it should write:
INFO_FORMAT=text/gml

changing from
INFO_FORMAT=ogr/gml
to
INFO_FORMAT=text/gml

will return a working GML response.

But of course in the wrong epsg reference system.
Because qgis will request only in epsg:4326.

History

#1 Updated by aperi2007 - almost 9 years ago

I check the GetCapabilities.

It report this availables formats.

<GetFeatureInfo>
<Format>text/gml</Format>
<Format>text/html</Format>
<Format>text/plain</Format>
<Format>ogr/gml</Format>
....

The right format for a compatible GML response is "text/gml"
Instead actually qgis-dev is using the "ogr/gml".

Is better thaat qgis will use the text/gml to have a response compatible with that of others server GML.

#2 Updated by aperi2007 - almost 9 years ago

  • Category set to Web Services clients/WMS

Also the request should do on the same reference system of the canvas not always in the epsg:4326.

#3 Updated by aperi2007 - almost 9 years ago

  • Resolution set to invalid

Hi,
I remove the "ogr/gml" format from the server settings.

Now the GetCapabilities will give this options:

<GetFeatureInfo>
<Format>text/gml</Format>
<Format>text/html</Format>
<Format>text/plain</Format>

So I retry the identify with QGIS-dev.

It still do nothing.

The log will report that the qgis-dev has send this request:

http://web.regione.toscana.it/wmsraster/com.rt.wms.RTmap/wms?map=wmsambamm&map_resolution=96&language=ita&&SERVICE=WMS&VERSION=1.3.0&REQUEST=GetFeatureInfo&BBOX=636170.8467062999261543,4837193.0576265491545200,679256.4274609615094960,4865692.6434558629989624&CRS=EPSG:25832&WIDTH=833&HEIGHT=551&LAYERS=rt_ambamm.idcomuni.rt.poly&STYLES=&FORMAT=image/png&QUERY_LAYERS=rt_ambamm.idcomuni.rt.poly&INFO_FORMAT=text/gml&I=423&J=185&FEATURE_COUNT=10

If I try the same request on a firefox browser I can see that the wms server response is a correct GML style.

I don't know why the qgis-dev is still not understanding the GML response, but otherwise now the wms server is responding correctly.

So I close this ticket.

#4 Updated by Jürgen Fischer almost 9 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF