Bug report #7113

QGS project files containing openlayers layers make QGIS crash when openlayers not setup

Added by Gen Gill almost 8 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System:Windows X64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:16187

Description

Hello to all,

It's all in the subject.
I tried to open a QGS file containing openlayers layers right after my QGIS setup through OSGEO4W and it crashed at the point where it was loading openlayers layers.
I setup openlayers and then it went ok.
More generally, QGS project files periodically and very regularly crashes QGIS, often when upgrading versions on my Windows OSGEO4W setup. About once every three months per project, which is quite a lot. Is it the same on Ubuntu or other Linux distributions ?
Am I the only one to suffer from this and if not could it be possible to make Qgis more stable with these files, loading only valid layers and poping the usual warning when necessary ?
Thanks to all developpers for the great work.

Gen.

History

#1 Updated by Giovanni Manghi almost 8 years ago

  • Status changed from Open to Feedback

I cannot confirm here on qgis master/linux, what happens is that qgis pops up the "missing layer" dialog.

Please test with a minimal project, if not done already. Tanks!

#2 Updated by Giovanni Manghi almost 7 years ago

closing for lack of feedback.

#3 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Also available in: Atom PDF