Bug report #7112

Identify feature on a splitted polygon does not return attributes properly on one of the two parts

Added by Olivier Dalang almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16186

Description

Hi !

Just after splitting a polygon, while still in editing mode, one of the two parts does not display any attributes with the Identify Feature tool.

After quitting the editing mode, both parts have the right attributes.

This is a cosmetic problem for the Identify Feature Tool, but is very annoying when you open the Feature Form, since it will reset all values to null.

The bug does not exist in 1.8.

Regards,

Olivier


Related issues

Related to QGIS Application - Bug report #7267: loss of attributes during split feature operation Closed 2013-03-03

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Target version set to Version 2.0.0
  • Priority changed from Normal to Severe/Regression
  • Category set to Vectors

if is a regression is a blocker.

#2 Updated by Alexandre Neto over 6 years ago

I can confirm this behavior in split feature in 1.9. Both identify tool and feature form tool doesn't show any attributes for one of the resulting feature. In the table of attributes all attributes are listed correctly.

#3 Updated by Giovanni Manghi over 6 years ago

  • Category changed from Vectors to Digitising

#4 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF