Bug report #711

GRASS plugin compile error: GRASS_VERSION_MAJOR etc. no longer strings

Added by Markus Neteler over 12 years ago. Updated over 12 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:10770

Description

Currently QGIS no longer compiles with GRASS 6.3.CVS since the include/version.h was modified to:

bartok:grass63[296.2] cat include/version.h
#define GRASS_VERSION_STRING   "@(#) 6.3.cvs (2007)" 
#define GRASS_VERSION_MAJOR    6
#define GRASS_VERSION_MINOR    3
#define GRASS_VERSION_RELEASE  cvs

Here the change from Glynn:

http://freegis.org/cgi-bin/viewcvs.cgi/grass6/include/version.h.in.diff?r1=1.4&r2=1.5

And a comment from Glynn:

http://grass.itc.it/pipermail/grass-dev/2007-April/030658.html

I'm afraid that this needs to be conditionalized. The QGIS code is in src/providers/grass/qgsgrass.cpp, lines 988 and following.

Compare the related GDAL-GRASS plugin changes at

http://trac.osgeo.org/gdal/ticket/1587

Sorry for the mess,
Markus

History

#1 Updated by Martin Dobias over 12 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #712

Also available in: Atom PDF