Bug report #71

Incorrect scale calculation (for large scales)

Added by Redmine Admin about 14 years ago. Updated almost 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10130

Description

1. Load any vector layer with long/lat map of the world

2. In full zoom it shows "Scale 1 : 73" (evidently incorresct value)

3. If Zoom In button is clicked map view changes to about 1 : 50 000 000 (it's already correct value)

It's especially annoying if Scale dependent rendering is set because layers which would show only in detailed view are also shown in full zoom (in general in large scale zoom)

Note: Map units were set properly

History

#1 Updated by anonymous - about 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in SVN 69e2ffb9 (SVN r5281)

#2 Updated by Redmine Admin about 14 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

The problem still remains :-(

#3 Updated by Gavin Macaulay - about 14 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Fixed (this time for good, I hope:) in SVN

#4 Updated by Anonymous almost 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF