Bug report #708

QGIS crash on incorrect GRASS vector maps

Added by Markus Neteler over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10767

Description

When browsing the available vector maps in a mapset,
QGIS crashes if it lists a vector map which is broken for whatsoever reason (also broken in GRASS). QGIS should
just skip such map and not get killed by it.

qgis
[...]
Loaded /usr/local/lib/qgis/lib/qgis/libwfsprovider.so
Loaded /usr/local/lib/qgis/lib/qgis/libwmsprovider.so
[[QgsGrass]]::vectors()
[[QgsGrass]]::vectors()
error_routine (fatal = 1): Cannot open existing vector <[email protected]> on level r2

Test case (Spearfish):

g.copy vect=roads,myroads

Now delete the 'coor' file:
rm spearfish60/YOURMAPSET/vector/myroads/coor

open QGIS and scroll the available vector maps and
it will crash once it reaches 'myroads'.

This also happened if a DB link to an external DB was lost, so it would be good to have this problem trapped.

Markus

History

#1 Updated by Maciej Sieczka - over 13 years ago

This is much more critical issue than it seems. Since QGIS tends to corrupt GRASS vectors (#550), this bug is very likely to crop out for anyone using QGIS to edit his GRASS vectors.

#2 Updated by Markus Neteler almost 13 years ago

Does this persist? AFAIK there was a workaround this added for 0.9.0 (G_fatal_error() behaviour, see GRASS-dev ML discussions).

#3 Updated by Martin Dobias almost 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Ah, this is exactly the same problem as with #110, I'm closing this too.

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.8.2 deleted

Also available in: Atom PDF