Bug report #7045

Don't use ilike operator for MSSQL provider

Added by Jeremy Palmer over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:Tamas Szekeres
Category:Data Provider/MSSQL
Affected QGIS version:master Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:16133

Description

Default MSSQL instances complete case insensitive searches with the equals and like operators. The QGIS query builder dialog has the option to use the 'ILIKE' operator, but MSSQL does not support this. Maybe the MSSQL provider should map ILIKE to LIKE before passing it to the server..?

History

#1 Updated by Tamas Szekeres over 6 years ago

  • Resolution set to wontfix

I don't think it would be a good approach to rewrite the operator at driver level.
We should probably establish a mechanism to disable the ILIKE button is the driver doesn't support this operation. However I don't think it would provide the amount of benefit comparing to the required amount of work to implement it.

This approach seem fairly reasonable to me since the driver provides notification that this operation is not supported.

Since we can use the lower(fieldname) LIKE lower(pattern) workaround I close this issue.

#2 Updated by Tamas Szekeres over 6 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF