Bug report #7009

QGIS crashes when using merge selected feature / merge attributes tool

Added by Alessandro Ciali over 6 years ago. Updated over 6 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:window Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:16109

Description

1.select at least 2 feature
2.select merge selected feature / merge attributes tool
3.in the window tool, choose the feature to take attribute from
4. QGIS crashes

verified on current master, while tool worked without problems in 12d1a28 and 1.8
win7 64bit
I hope it will be useful, waiting for feedback
bye

sample_data.zip (1.89 KB) Alessandro Ciali, 2013-01-18 08:32 AM

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

should be duplicated of #6902

as in my case I was not able to replicate the crash it would be useful to attach sample data.

#2 Updated by Alessandro Ciali over 6 years ago

the probles seems to get bigger in time, because the nigthly build version 12d1a28 didn't crash by simply transferring the attribute of one feature without min, max or other operation. I think this could be an upgrade of #6902

#3 Updated by Giovanni Manghi over 6 years ago

Alessandro Ciali wrote:

the probles seems to get bigger in time, because the nigthly build version 12d1a28 didn't crash by simply transferring the attribute of one feature without min, max or other operation. I think this could be an upgrade of #6902

ok, sample data would be useful anyway.

#4 Updated by Alessandro Ciali over 6 years ago

I send a sample data with 2 polygon: selecting merge tool and choosing the feature whose attributes will be transferred causes GQIS to crash.

#5 Updated by Alessandro Ciali over 6 years ago

Tested the last master 969df01. I don't know what the solution was, but the problem seems to be resolved. By the way I will permorm further tests just to be sure. Fell free to clos the ticket.

#6 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

duplicate of #6902

Also available in: Atom PDF