Bug report #6952

raster "save as..." dialog creates incomplete output when using the " create VRT" option

Added by Giovanni Manghi almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:16062

Description

Open the attached project,

in the (only) WMS layer click the "save as..." option.

Leave the "create VRT" option checked and in the CRS dropdown choose EPSG 3763. Then choose to save the "map view extent" and choose as resolution "5".

The resulting output VRT will miss a few vertical strips. See attached image.

saveas.qgs (5.86 KB) Giovanni Manghi, 2013-01-06 12:58 PM

Capture.PNG (1.38 MB) Giovanni Manghi, 2013-01-06 12:58 PM

teste_wms.qgs (5.96 KB) Giovanni Manghi, 2013-05-16 04:06 AM


Related issues

Duplicates QGIS Application - Feature request #6951: raster "save as..." to be improved when asking for output... Open 2013-01-06

History

#1 Updated by Radim Blazek over 6 years ago

  • Status changed from Open to Feedback

#2 Updated by Giovanni Manghi over 6 years ago

Radim Blazek wrote:

The server is giving Internal server error:
http://data1.geoposer.com:443/server/services/request.php?jname=/wms.img&&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&BBOX=-8.3253071840480519,38.5151373813695059,-8.0875913241040838,38.6766480462664717&SRS=EPSG:4326&WIDTH=1264&HEIGHT=860&LAYERS=Virtual%20Earth&STYLES=&FORMAT=image/jpeg&DPI=85&MAP_RESOLUTION=85&FORMAT_OPTIONS=dpi:85

I tried with another WMS server and it worked OK. Could you test again and if it still fails for you, please send a working WMS URL or project file.

I attached a new project you can try.

The output changed, now it is completely empty.

cheers!

PS
issue #6951 is not duplicate of this one.

6951 is about that the user cannot choose the name of the output vrt.

#3 Updated by Giovanni Manghi over 6 years ago

see also #6982

#6 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF