Bug report #6867

Editorlayout is not saved in project file for a non-spatial spatialite table

Added by Josef Källgården almost 9 years ago. Updated almost 9 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:16000

Description

I can connect a custom form to both a spatial and a non-spatial spatialite table.
But only for the spatial table is the attribute editor layout setting (properties-fields tab) stored in the qgis project file.

I think this is a regression since it earlier was possible to connect a custom form to a non-spatial table and also keep information about this connection in the qgis project file.

A sample qgis project, spatialite db and custom form is attached. See project file where <editorlayout>uifilelayout</editorlayout> is only set for the spatial table.

editorlayouttest.zip (6.38 KB) Josef Källgården, 2012-12-12 03:56 PM

History

#1 Updated by Matthias Kuhn almost 9 years ago

  • Status changed from Open to Resolved

Should be fixed as of https://github.com/qgis/Quantum-GIS/pull/364.

Please reopen if necessary.

#2 Updated by Matthias Kuhn almost 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF