Bug report #6863

Bad layer handling after reopening a project with Openstreetmap plugin data

Added by Andre Joost over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No

Description

Openstreetmap plugin saves data in a temproary database. When saving and reopening a project with OSM data, I get the "bad layer handling" dialogue for the layers OSM plugin had created.

The downloaded data and database are still in temp directory, but the plugin can't open the layers.

Exporting to shapefile or spatialite is not an option, because the styling from OSM plugin can not be copied to other layers.

Tested on Qgis Lisboa and current Master.

History

#1 Updated by Martin Dobias over 4 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

The new OpenStreetMap implementation in 2.0 does not use temporary database anymore... closing.

Also available in: Atom PDF