Bug report #6856

pdf error 14 when generating Atlas with transparent overview frame

Added by Regis Haubourg almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15990

Description

Hi all,
when generating batch pdf with Atlas, if a map has an overview frame set with transparent fill, then pdf are corrupted.
With adobe reader, opening pdf is impossible (raise error 14). Foxit reader opens pdf but overview frame are no more transparent.

I found a workaround with setting no fill in overview frame style, but it is a caveat since default style has a fill and generates corrupted pdfs.

Régis

carte_EPCI_63.pdf (1.84 MB) Regis Haubourg, 2012-12-12 02:00 AM

Associated revisions

Revision 7db1b607
Added by Hugo Mercier over 6 years ago

refs #7263
refs #6856
Reset QPrinter to circumvent PDF corruption bug

History

#1 Updated by Regis Haubourg almost 7 years ago

New tests, and we again have an inconsistent behaviour... In other situations, overview frame have nothing to do with pdf export problems..
I keep on testing.

#2 Updated by Regis Haubourg almost 7 years ago

a new clue: Problem only affects vector export.

#3 Updated by Hugo Mercier almost 7 years ago

Hi,
Does it work ok without atlas generation ?

I've just produced a pdf with an atlas from a vector layer and with a transparent overview, and it works fine with Evince (Linux) and Adobe reader 10.1.14 under Windows. The pdf has been generated from a Linux version of QGIS.
Can you add here the corrupted pdf you obtain (there might be differences in the way pdf are generated by Qt under Windows) ?

#4 Updated by Regis Haubourg almost 7 years ago

Hi Hugo,
I've never reproduced this problem outside Atlas use-case. Please find attached a corrupted pdf. I use Adobe reader 9.5.2 and Foxit 5.4.3.0920. Windows XP 32 bits.
Hope it helps

#5 Updated by Hugo Mercier almost 7 years ago

Ok, I can reproduce the problem. Adobe reader gets an error. xpdf on linux crashes.
The overview frame with evince is not transparent.

#6 Updated by Alessandro Ciali almost 7 years ago

I suggest to look also at Bug #6741, that I opened about a month ago.
Good bye

#7 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from High to Normal

#8 Updated by Olivier Dalang almost 7 years ago

Same problem with labels here, when labels have transparent background.

Note that the first exported file (the PDF corresponding to the first feature) is exported well...

#9 Updated by Olivier Dalang almost 7 years ago

  • % Done changed from 0 to 80

Here's a bugfix :

https://github.com/olivierdalang/Quantum-GIS/tree/bugfix_6856

I'm a newbie in C++ programming, and my fix doesn't seem very elegant to me... It would be nice if someone could confirm if it's acceptable.

#10 Updated by Regis Haubourg over 6 years ago

  • % Done changed from 80 to 100
  • Status changed from Open to Closed

Hi all,
I couldn't reproduce problems now. Please reopen if necessary

Also available in: Atom PDF