Bug report #6850

QGis crash when deleting nodes

Added by Samy MEZANI almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Digitising
Affected QGIS version:1.8.0 Regression?:No
Operating System:Debian GNU/Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:15986

Description

When I delete one or several nodes in an edited polygon layer in SHP format, QGis crash.
The backtrace log and an archive of the layer are joined.

Qgis version : 1.9.90+git20120612+5ebdbe3~unstable1

backtrace.txt Magnifier (15.5 KB) Samy MEZANI, 2012-12-10 02:26 AM

parcelles_favorables.7z (62.8 KB) Samy MEZANI, 2012-12-10 02:26 AM

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Target version changed from Branch - Advanced Editing to Version 2.0.0
  • Status changed from Open to Feedback
  • Category changed from Vectors to Digitising

have you tested qgis master? It should be fixed there. Please try and report back.

#2 Updated by Samy MEZANI almost 7 years ago

  • Status changed from Feedback to Closed

OK, the problem is fixed with version 1.9.0+git20121208+7841975~unstable1
I don't understand why my qgis version was not updated with the latest on repository http://qgis.org/debian-nightly, but it's an other problem.

Thanks !

Also available in: Atom PDF